I’ve just started turning off my PC when I’m done with it because a mouse farting on the mouse will wake it up. Also if I do manage to get it to sleep it wakes itself up every few hours to check for updates.


This has literally been a problem since Windows ever came into being. I remember long nights of wrestling with this garbage on Jurassic versions of Windows.


Btw, if my pc wakes up seconds after if try to manually via XfCE power menu, but sleeps fine by itself (20 minutes inactivity), what could that be?


Check journal, you should see either an error or a wakeup reason


Check the BIOS/firmware, there are different sleep states for Windows and Linux that can be configured. Some just refuse to sleep properly. I had a Dell laptop that would sleep and then wake up when I closed the lid and then stay awake.

Netrunner, avatar

This article is a wall of text spreading fake info. The sleep states work fine in windows if you have any idea how it works. And this has been the case for at least 8 years.

If you have any issue go into cmd type powercfg -requests and windows will tell you what is keeping it awake.

And doubling down if you really want your pc to wake if its off and you slap your keyboard just tweak your bios wake options and done.

QuarterSwede, avatar

My work issued E15 Ryzen 5000 sleeps and hibernates fine. Plus it lasts a long time in both. I wonder if it’s an Intel bug.


Isn’t that a Lenovo model? I noticed they weren’t mentioned in the article and wondered if that was on purpose or just an oversight. My cheap IdeaPad also sleeps fine…but it also has an AMD cpu.

QuarterSwede, avatar

Yes. Lenovo E15. Excellent work laptop honestly.


Hibernate is a different function

QuarterSwede, avatar

Yet they’re linked. Still, the machine has zero issues with Windows sleeping.


Yeah just what I want from my PC: for it to be more like the always-on, nagging attention whore that is my phone. /s


This is why I always shut down and never sleep it. With my nvme drive boot up is seconds.


I dunno why I individually responded to people when I should’ve just done this.

It’s because one of your peripherals is set to wake state. You can google how to figure that out.

I turned my mouse and keyboard off from this. The mouse will wake it even if you move it. So f that. Keyboard. Some. Keyboards will wake just by having an active transmission (so manually turn it off every time - no thanks)

Now I manually have to touch my power button to wake.


My macbook wakes up whenever I get up in the middle of the night to pee. This is without me touching the mouse or the keyboard or even the desk they’re sitting on. This bothers me.


Well that’s a separate issue. You have some Apple feature turned on and it needs turned off.


MacBook: “Oh, hey chickenlady… I see your up. Yeah, I couldn’t sleep either. Why don’t you come over here and spend some time in my soft white glow. We can just surf the web and consume for hours.”


This is an issue, but it’s not the issue. The issue is windows modern standby, trying to make users PCs always on like smartphones. Except the processors don’t support the same low power states as smartphones processors, and can be triggered by software like windows update to turn on even when disconnected from power and without functioning ventilation.

seaQueue, avatar

It’s because one of your peripherals is set to wake state. You can google how to figure that out.

Sometimes that’s a firmware issue. ASUS screwed up the ACPI DSDT for my 2021 G15 by leaving the sleep capabilities off of one of the NVMe slots - every time you’d tell the machine to sleep it would try, but because one of the NVMe slots wasn’t capable the machine would then immediately rewake. I had to decompile the damned thing, patch it and load my patched table as an in memory override every single boot.


Well that’s impressive AF.


Hahaha that’s king to angrily fix it yourself

wander1236, avatar

This is true for S3 sleep, but that’s not the issue here. S0 sleep or Modern Standby just doesn’t put the computer to sleep. Windows manages device power states instead of the BIOS, and it usually doesn’t work out so well.

Overheating and battery drain caused by Modern Standby happen on laptops that are closed with nothing plugged in.


The “allow device to wake up computer” is already set to “off” in mouse, keyboard and other USB devices, together with any bios settings related to wake up. Yet still, at least once a week my computer is on in the morning, after i set it to Hibernate the night before. Sometimes it even power cycles straight away after i tried to turn it of. Same today, when i was was out of the house for a few hours, and it decided to magically turn itself on, run windows update and restart. I have to power it down and turn of the the power on the power-strip each night. My work laptop has the same issue, except it does not care about the power strip switch and discharges the battery overnight instead!


I actually like suspend to RAM. Makes my laptop usable after sleep a bit faster. But absolutely not on Windows because then my fans are still spinning after minutes like many have reported. But I was simply able to disable that with a registry tweak and it’s now going to regular ACPI S3 when I close the lid. Is my Framework Laptop 13 (i5-1240P) an uncommon exception?


Does suspend to ram drain battery?


Yes depending on the sleep state. Also some power is going to ram to keep it alive. I think for framework it’s in the realm of 5% an hour or something like that.

I usually go the hibernation route.

Desktops I sleep to ram, laptops I hibernate to the SSD.

Fal, avatar

Is my Framework Laptop 13 (i5-1240P) an uncommon exception?

Yes. Laptop manufacturers are disable s3 sleep in firmware. Framework explicitly gives that freedom because they don’t suck


This also happens on Linux, after 20 seconds, my computer just wakes up 😠 (definitely not because I don’t have enough disk space)


It’s because one of your peripherals is set to wake state.

I turned my mouse and keyboard off from this.

Now I manually have to touch my power button to wake.


Had the nic set to that. Any package on the network. Did not matter who it was for. If the nic saw it, it would wake the machine up.


You didn’t get it. It’s because I didn’t have enough disk space, my partition was too small. I also deleted files from the trash and it works.


Try to put my PC to sleep? 1 of 3 things happens: it either goes to sleep normally, it goes to sleep but wakes itself up 2 seconds later, or the PC actually just shuts down. Try to shut down my PC? 1 of 2 things happens: it either shuts down, or it restarts.

I think the problem is Windows.

at_an_angle, avatar

Is not just me!


It’s because one of your peripherals is set to wake state.

I turned my mouse and keyboard off from this.

Now I manually have to touch my power button to wake.


Turned your mouse and keyboard off?

Turned your wake state checker to not check for keyboard and mouse?

What does “from this” mean? Curious how this works


The only way for me to keep my desktop off all night is for me to switch off the power supply or unplug it, sleep, hibernate, flat out turning it off, all result in a bright ass screen waking me up at 2am


You can go into the window settings until it to shut down all the way. My computer used to do that too, until I disabled the setting.


There was a video from LTT not too long ago where they contacted MS about the issue. It’s supposedly due to device manufacturers not implementing the spec properly so they ended up giving up on it.

Pxtl, avatar

I had the same problem with my work-issued Thinkpad. No overheating, but frequently pulling the laptop out of the bag and finding battery dead. Solution I found was to bind the power-button to “hibernate”, and just using that any time I knew I was going to be putting it away into my bag.

One problem I ran into writing my first Windows Store application like 10 years ago was that Windows Store seemed to have no interest in mobile-style security where you request permissions one-at-a-time and only the ones you need - the intended workflow was that you either requested no secure privs and let your app be “untrusted”, or you made your app “trusted” and requested all the privs. This was actively recommended by MS.

Of course, this means “wake from sleep” would be something that every app would have permission to do accidentally, even if they didn’t want to.


Yep, while my Extreme Gen 4 has a BIOS toggle, my work-issued T14 Gen 3 does not so I had to get IT to come in and enable hibernate. Prior to that it seemed like it had less battery life sleeping than awake. (ex: fully charged and confirmed that the power light is flashing before flight - few hours later it’s 100% dead.)


It’s because one of your peripherals is set to wake state.

I turned my mouse and keyboard off from this.

Now I manually have to touch my power button to wake.

Pxtl, avatar

It didn’t have any peripherals, I mean, like, external USB ones.


I managed to fiddle around with my work Dell laptop and disable that nonsense. I think it was called “modern standby”. I don’t understand why this isn’t considered a fire hazard. It was terrifying to leave my laptop in my backpack until I figured out the fix.


My ARM laptop is great. Was dirt cheap and it’s pretty damn good for what it is


wow they’re just like me


Can anyone explain how this is different from Power Nap on Macs? I’ve never heard anyone upset about that.


LTT had a great video on that. Basically Windows has a bug which sometimes prevents this sleep mode from working correctly and that nukes battery life. Microsoft has promised a fix, but apparently it’s not resolved still. In theory it should work exactly the same as Power Nap. It sometimes does, but sometimes - not so much.

P.S. Power Nap used to be buggy as well, but Apple fixed it years ago.


Thanks for the details! When Power Nap was new I didn’t have a Mac that could use it. I think it used newer Intel tech than what my Mac had at the time IIRC.


Decades old bugs aren’t uncommon on Microsoft products.


I have one laptop running Windows and I just changed the BIOS/UEFI setting so that closing the display turns off the computer.

Also handy for Linux distros with poor standby/sleep support.

ChaoticNeutralCzech, (edited ) avatar

Pretty drastic, I can imagine losing some work accidentally because of that (closing with improper connection to external monitor). Why not hibernate?


Really depends on your devices use case. That isn’t my daily driver and the trade off of not having a dead laptop is worth it for my needs of this device.

Zeroxxx, avatar

It is pretty reliable. In all Windows 10 years I have never had any issue with that method as well. Besides, I save often.

  • All
  • Subscribed
  • Moderated
  • Favorites
  • All magazines